Software Requirements - 1.1 English

AI Optimizer User Guide (UG1333)

Document ID
UG1333
Release Date
2020-07-07
Version
1.1 English

Install GPU related software according to the operating system. For Ubuntu 16.04, install cuda9.0, cuDnn7 and Driver 384 or above. For Ubuntu18.04, install Cuda10.0, cuDnn7 and Driver 410 or above.

  • Nvidia GPU Drivers

    Install GPU driver by apt-get or directly install the cuda package with driver. For example:

    apt-get install nvidia-384
    apt-get install nvidia-410
  • CUDA Toolkit

    Get the cuda package associated with the Ubuntu version from https://developer.nvidia.com/cuda-toolkit-archive and directly install the NVIDIA .run package.

  • cuDNN SDK

    Get cuDnn from https://developer.nvidia.com/cudnn and append its installation directory to the $LD_LIBRARY_PATH environmental variable

    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cudnn-7.0.5/lib64
  • CUPTI

    CUPTI is required by vai_p_tensorflow. It is installed together with CUDA. We need to add CUPTI directory to the $LD_LIBRARY_PATH environment variable. For example:

    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cuda/extras/CUPTI/lib64
  • NCCL

    NCCL is reqired by vai_p_caffe. Download NCCL from its homepage (https://developer.nvidia.com/nccl) and install.

    sudo dpkg -i nccl-repo-<version>.deb
    sudo apt update
    sudo apt install libnccl2 libnccl-dev