Configuring the Vitis Analyzer - 2021.2 English

Vitis Unified Software Platform Documentation: Application Acceleration Development (UG1393)

Document ID
UG1393
ft:locale
English (United States)
Release Date
2021-12-15
Version
2021.2 English

The Tools > Settings command opens the Vitis Analyzer Settings dialog box as shown below.

Figure 1. Settings Dialog Box

In the General settings, the following can be configured:

Default Directory
Specifies the default directory used by the Vitis™ analyzer when it is opened.
Recent
Configures the tool to restore the workspace when reopening the Vitis analyzer, and specify the number of entries to display for File > Open Recent commands.
Report Tabs
Defines the number of reports and views that can be opened in the main Reports window.
In the Display settings you can configure the following features of the display:
Scaling
Sets the font scaling to make the display easier to read on high resolution monitors. Use OS font scaling uses the value set by the OS for your primary monitor. User-defined scaling allows you to specify a value specific to the Vitis analyzer.
Spacing
Sets the amount of space used by the Vitis IDE. Comfortable is the default setting. Compact reduces the amount of space between elements to fit more elements into a smaller space.
The Reports section configures the Vitis analyzer to also open specified reports when opening the Compile Summary, Link Summary, Run Summary, or Binary Container reports:
Compile Summary
Select which reports are listed in the Report Navigator view, and opened with the Compile Summary.
Link Summary
Select which reports are listed and opened with the Link Summary.
Run Summary
Select which reports are listed and opened with the Run Summary. Also, select which reports are dynamically updated while the application is running. Timeline Trace reports can be automatically reloaded when continuous trace data is captured as described in Continuous Trace Capture. This lets you observe the trace data in Vitis analyzer as it is captured from your running application.
Binary Container
Select which reports are listed and opened with the Binary Container.
AI Engine Compile Summary
Select which reports are listed and opened with the AI Engine Compile Summary.
AI Engine Run Summary
Select which reports are listed and opened with the AI Engine Run Summary.

For Window Behavior settings, the following can be configured:

Warnings
Shows warning when exiting or just exits the Vitis analyzer.
Alerts
Issues an alert when you are running the tool on an unsupported operating system.

After configuring the tool, click OK, Apply, or Cancel. You can also use the Restore command to restore the defaults settings of the tool.

Layout

The Vitis analyzer also lets you arrange reports in different layouts, and save those layouts for reuse. This allows you to arrange two reports for comparison, or to check one report against the other. The Layout menu in the main menu lets you switch between existing layouts, or save a custom report layout using the Save Layout As command. You can also Reset Layout to return it to its saved configuration, or Remove Layout to eliminate saved layout.