Adapter Driver/Firmware Support

Enhanced PTP User Guide (UG1602)

Document ID
UG1602
Release Date
2022-10-18
Revision
1.0 English

This section identifies the minimum software components required to support time synchronization server adapters:

  • To identify Solarflare-designed adapters in a server, run the following command:
    # lspci -vvv -d 1924:

    The following command typically extracts the adapter name from the above output:

    # lspci -vvv -d 1924: | egrep 'Product|Subsystem'
  • To identify more recent Xilinx-designed adapters in a server, run the following command:
    # lspci -vvv -d 10ee:

    The following command typically extracts the adapter name from the above output:

    # lspci -vvv -d 10ee: | egrep 'Product|Subsystem'
  • To identify the net driver and firmware versions used by the adapter run the following command where <interface> is the Linux interface name:
    # ethtool -i <interface>
Table 1. Minimum software components required
Adapter Linux Net Driver Controller Firmware
X3 series xilinx_efct, any version Any
X2 series sfc, any version that supports adapter Any
SFN8542
SFN8522
SFN7142Q sfc v4.1.0.6734 v4.1.1.1022
SFN7322F sfc v4.0.2.6628 v4.0.6.6689
SFN7122F
SFN7002F
HP 570FLB sfc v4.0.2.6628 v4.0.7.6711
HP 570M
SFN6322F sfc v3.3.0.6246 v3.3.0.6247
Important: The sfptpd daemon must be terminated before upgrading the adapter firmware.