Unexpected Driver Version String 4.0

Enhanced PTP User Guide (UG1602)

Document ID
UG1602
Release Date
2022-10-18
Revision
1.0 English
Figure 1. Flowchart for Unexpected Driver Version String 4.0

This error message might be observed in the sfptpd stats_log/message_log during sfptpd startup.

The Linux ‘in-tree’ driver is the Solarflare adapter driver distributed with the Linux OS. This is normally the 4.0 or 4.1 version driver.

This driver gives poor performance with sfptpd 3.5.0 onwards, and cannot be used with earlier versions of sfptpd.

The driver should be upgraded to a later version from the NIC Software and Drivers downloads page on the Xilinx website.

The driver being used by the network adapter can be identified using the following command:

# ethtool -i <interface>
driver: sfc
version: 4.0
firmware-version: 4.7.1.1001 rx1 tx1